Welcome to InspirePilots.com

Join the leading DJI Inspire community for free!

Battery Will Not Charge

Discussion in 'Inspire 1 Help' started by tweaker, Mar 15, 2016.

  1. tweaker

    Joined:
    Feb 1, 2015
    Messages:
    340
    Likes Received:
    76
    Hi

    Any help gladly taken on board TB 47 will not charge.

    I can fire up the battery and have 25% left on it on the GO APP. Two leds on battery.

    However it will not charge up. Attach it to charger and the lights just stay on(two leds) but they do not "flow" as if its its charging.

    I have looked after the battery and deep cycled it etc as required.

    Any others had this problem?

    Oh almost forgot battery has 54 flights on it.

    Thanks any advance.
     
  2. tweaker

    Joined:
    Feb 1, 2015
    Messages:
    340
    Likes Received:
    76
    Just seen other TB47 Post "will not charge"-apologies.

    Please move if required
     
  3. The Editor

    The Editor Moderator
    Staff Member

    Joined:
    Aug 7, 2013
    Messages:
    6,734
    Likes Received:
    3,891
    Although it says circa 25% in the app, flip over into the battery screen and look at the individual cell voltages.
    What do they look like?
     
  4. tweaker

    Joined:
    Feb 1, 2015
    Messages:
    340
    Likes Received:
    76
    Just taken it off charge now.

    Still trying to rectify fault.

    It shows 3.74 v battery life 98% on battery screen,22.4v voltage,remain power 891 mAH,Total Capacity 4244mAH.
     
  5. The Editor

    The Editor Moderator
    Staff Member

    Joined:
    Aug 7, 2013
    Messages:
    6,734
    Likes Received:
    3,891
    OK, try a couple of things.
    1. Turn the battery on BEFORE connecting it to the charger (as though you were doing a top off at over 95% charge). This may kick start the pack into charging.
    2. You can try the top off and disconnect trick on the battery if the above fails.
     
  6. tweaker

    Joined:
    Feb 1, 2015
    Messages:
    340
    Likes Received:
    76
    Tried above previously.

    However just tried no 1. above again.....

    1x LED came on and stayed on. Approx 60 secs later normal charging pattern -sweeping LEDs came on.

    Currently keeping fingers crossed will post back and let peeps know outcome.

    As always thanks for timely help.
     
  7. tweaker

    Joined:
    Feb 1, 2015
    Messages:
    340
    Likes Received:
    76
    Being naturally nosey any ideas whats the technical explanation as to why this happens on "intelligent" batteries. (Presuming this has fixed it!)
     
  8. The Editor

    The Editor Moderator
    Staff Member

    Joined:
    Aug 7, 2013
    Messages:
    6,734
    Likes Received:
    3,891
    Like most things electronic and processor controlled - occasionally they lose their marbles! (Happens to all of us sometimes).
    What I think happens is although the pack is only partially charged and the telemetry and voltage display shows this the battery 'thinks' it is sitting at over 95% and therefore will not initiate a charging sequence until you turn the battery on and then connect it.
    Sometimes this can occur if you only fly the pack for a few minutes say down to 3.8v per cell or so. Then when you land and the load is removed, the rebound of the cells produces a recovery back of around 0.2v per cell. This then puts the cell voltages at circa 4v. The intelligent (stupid) battery then thinks it's more charged than it is and places the 95% charge protection in place.
    Hope that makes sense.
     
  9. tweaker

    Joined:
    Feb 1, 2015
    Messages:
    340
    Likes Received:
    76
    Makes sense to me.

    Thought it was something to do with being"intelligent"

    As soon as someone/something calls themselves intelligent,champion,hardest,quickest,unbreakable etc etc I always view this blowing smoke up one selves as a jinx waiting to happen.

    Thanks anyway.
     
  10. The Editor

    The Editor Moderator
    Staff Member

    Joined:
    Aug 7, 2013
    Messages:
    6,734
    Likes Received:
    3,891
    Hope it solves the problem. :)
    Post back here if it did/does so others can see the solution.
     
  11. tweaker

    Joined:
    Feb 1, 2015
    Messages:
    340
    Likes Received:
    76
    Ok problem solved kind of.

    Battery charged up to 100%- all cells full.

    However pressing battery on showing 3 xLEDs.

    Any ideas?
     
  12. The Editor

    The Editor Moderator
    Staff Member

    Joined:
    Aug 7, 2013
    Messages:
    6,734
    Likes Received:
    3,891
    Yup - that should clear itself and work as expected (all four leds illuminated with full charge) after you next use the pack.
     
  13. tweaker

    Joined:
    Feb 1, 2015
    Messages:
    340
    Likes Received:
    76
    Test flight today.

    Battery re charges fully but only shows 3x LEDs when pressing for immediate batt check.
     
  14. The Editor

    The Editor Moderator
    Staff Member

    Joined:
    Aug 7, 2013
    Messages:
    6,734
    Likes Received:
    3,891
    This usually clears after the first use but sometimes can take two or three charge cycles. I have no idea why though.
    I have seen this happen on a few occasions and it has always cleared itself and never returned so I would expect yours to be the same.
     
  15. tweaker

    Joined:
    Feb 1, 2015
    Messages:
    340
    Likes Received:
    76
    Ok will monitor and report back so others can benefit.

    Thanks