Welcome to InspirePilots.com

Join the leading DJI Inspire community for free!

DJI Osmo Not working! Worst company!

Discussion in 'Osmo (Handheld Gimbal)' started by soamz, Apr 5, 2016.

  1. soamz

    Joined:
    Apr 6, 2014
    Messages:
    59
    Likes Received:
    0
    DJI Osmo costs 1100 USD in India, so I asked my sister to purchase it from Amazon and bring it while coming to India, for 558 USD, and she did. I just received the box, connected to my iPhone 6 plus, at first the live view came.
    It asked for firmware upgrade. I did it.
    And since the latest firmware has got installed, it seems to be dead. The live view doesnt work on both iPhone and Android app.

    Im able to see camera info, live view info, battery info, everything but cannot see anything what im doing or shooting.
    Also, not able to load the playback. as soon I click on playback, the wireless communication is lost with the OSMO.

    So, whats wrong ?

    Im really pissed, because I cannot even return it for replacement, as fedex would charge 400 USD to ship it back to USA.
     
  2. SanCap

    Joined:
    Sep 18, 2013
    Messages:
    1,330
    Likes Received:
    393
    Location:
    South West Florida
    How did you do the firmware update? By using your device or micro SD card?
     
  3. Mr Phantom

    Joined:
    Jun 19, 2015
    Messages:
    294
    Likes Received:
    25
    As far as i know DJI pays the shipping cost if it is a warranty case. At least thats what they do with the Inspire 1.
     
    #3 Mr Phantom, Apr 8, 2016
    Last edited: Apr 15, 2016
    Predator likes this.
  4. Predator

    Joined:
    Dec 29, 2015
    Messages:
    260
    Likes Received:
    65
    Location:
    Ottawa,Canada
    Look on your sd card see if it was a successful update or not.
     
  5. damoncooper

    Joined:
    Mar 20, 2014
    Messages:
    3,451
    Likes Received:
    1,620
    Location:
    Boston, MA
    Ditto here. No live feed. It's now a useless chunk sitting in my case
     
    SanCap likes this.
  6. SanCap

    Joined:
    Sep 18, 2013
    Messages:
    1,330
    Likes Received:
    393
    Location:
    South West Florida
    Damon, did you update via the app or sd card?
     
  7. damoncooper

    Joined:
    Mar 20, 2014
    Messages:
    3,451
    Likes Received:
    1,620
    Location:
    Boston, MA
    I have the problem where with latest X3 update and OSMO update, I have NO video in the GO app.

    OSMO update via app went successfully (after update via card initially failed) and X3 update on Inspire went successfully.

    Latest GO app. No video feed.

    I tried at DJI's suggestion:

    1) Re-install the DJI GO App.
    2) Check SD card, format it in the DJI GO App and reinstalled the firmware from card successfully
    3) Try Trigger + Record + Power Switch on startup.

    But still no video feed. Any other ideas?

    ImageUploadedByTapatalk1460209470.829412.jpg
     
  8. SanCap

    Joined:
    Sep 18, 2013
    Messages:
    1,330
    Likes Received:
    393
    Location:
    South West Florida
    I would try it again using the SD card one more time.