Welcome to InspirePilots.com

Join the leading DJI Inspire community for free!

DJI Pilo APP USB Disconnect Error

Discussion in 'DJI Go App' started by Max, Apr 13, 2015.

  1. Max

    Max

    Joined:
    Apr 13, 2015
    Messages:
    17
    Likes Received:
    1
    Hi guys ! Anyone using android devices to connect the DJI Pilot App ? yesterday i still can connect it with my samsung tab S 8.4 . Today i totally cannot connect it anymore , i did try few of my android phone and tablet with different cable but it still showing USB Disconnect and with a black screen on my devices . Is that the USB port problem ? anyone here face this problem before ?
    photo.JPG
     
  2. Buck windham

    Joined:
    Mar 30, 2015
    Messages:
    4
    Likes Received:
    1
    yes,i have a samsung tab s could not get usb to work. says usb debug .........
     
    Max likes this.
  3. Max

    Max

    Joined:
    Apr 13, 2015
    Messages:
    17
    Likes Received:
    1
    so windham is it the device problem ? have change another device?
     
  4. huppe

    Joined:
    Jan 11, 2015
    Messages:
    899
    Likes Received:
    317
    Yeap just what Lucan is saying Max.That's your problem.Work with a Tab 8.4 pro and it works fine.
     
  5. Mazz

    Mazz Moderator
    Staff Member

    Joined:
    Aug 9, 2014
    Messages:
    944
    Likes Received:
    585
    Location:
    NY
    Ya, try a different device and cable. Hopefully you don't have my issue. USB port failure. Controller at DJI now...
     
  6. Max

    Max

    Joined:
    Apr 13, 2015
    Messages:
    17
    Likes Received:
    1
    Yes Lucan , i already done the setting of USB Debugging
     
  7. Max

    Max

    Joined:
    Apr 13, 2015
    Messages:
    17
    Likes Received:
    1
    Huppe i done the USB debugging setting but it still not working with my device
     
  8. Max

    Max

    Joined:
    Apr 13, 2015
    Messages:
    17
    Likes Received:
    1
    Mazz you face the same problem aswell ? cant connect to any device ?
     
  9. Mazz

    Mazz Moderator
    Staff Member

    Joined:
    Aug 9, 2014
    Messages:
    944
    Likes Received:
    585
    Location:
    NY
    Yes, I had to send my controller in to DJI to have it repaired. The USB port stopped working over time. At first it would work with some reseting but I assume that was just me moving the cables that actually made it work because it eventually stopped working all together.

    Did you try other devices and other cables with no connection or sign of charging? That was my issue.
     
  10. Max

    Max

    Joined:
    Apr 13, 2015
    Messages:
    17
    Likes Received:
    1
    i try a few of my android phone and tablet with different cables as well , it still showing no connection , but it got sign of charging . Maybe i should try on IOS device see it is still the same problem ?
     
  11. Mazz

    Mazz Moderator
    Staff Member

    Joined:
    Aug 9, 2014
    Messages:
    944
    Likes Received:
    585
    Location:
    NY
    If it is showing a sign of charging it is not a USB port issue.
     
  12. Max

    Max

    Joined:
    Apr 13, 2015
    Messages:
    17
    Likes Received:
    1
    so is the device problem ?
     
  13. Mazz

    Mazz Moderator
    Staff Member

    Joined:
    Aug 9, 2014
    Messages:
    944
    Likes Received:
    585
    Location:
    NY
    It sounds like it. When I called DJI we went through trouble shooting and charging or not charging was the final thing they checked. Said if it won't charge the port was probably dead. If yours works I would assume it is a device or cable issue.
     
  14. Max

    Max

    Joined:
    Apr 13, 2015
    Messages:
    17
    Likes Received:
    1
    alright ^^ i go try with the ios device see it is work or not !
     
  15. Buck windham

    Joined:
    Mar 30, 2015
    Messages:
    4
    Likes Received:
    1
    Yes it works OK with ipad. But samsung works good otherwise? Maybe a setting or software issues?
     
  16. tuxevil

    Joined:
    Apr 1, 2015
    Messages:
    118
    Likes Received:
    22
    it happened to me, i shutdown completely and restart and it worked

    seems usb debugging was "bugged" (LOL)
     
  17. Max

    Max

    Joined:
    Apr 13, 2015
    Messages:
    17
    Likes Received:
    1
    Yup i think is the usb debugging problem!
     
  18. huppe

    Joined:
    Jan 11, 2015
    Messages:
    899
    Likes Received:
    317
    Mmm strange I did have the same problem with my Samsung and after debugging and a restart everything worked well.I'm out of solutions Max,
     
  19. Max

    Max

    Joined:
    Apr 13, 2015
    Messages:
    17
    Likes Received:
    1
    i try it and re-install app and again format my tablet it still not working !
     
  20. Buck windham

    Joined:
    Mar 30, 2015
    Messages:
    4
    Likes Received:
    1
    thank you every one.... buck