Welcome to InspirePilots.com

Join the leading DJI Inspire community for free!

Is firmware v.1.6.0.40 ok for X5 or just X3?

Discussion in 'Inspire 1 Help' started by Quarts, Feb 10, 2016.

  1. Quarts

    Joined:
    Nov 3, 2015
    Messages:
    10
    Likes Received:
    0
    Stupid question maybe, but when looking at firmware downloads available on the Inspire 1 Pro section on DJI´s website the latest one is v.1.3.0.60 while v.1.6.0.40 is available on the Inspire 1 downloads section.

    Is the v.1.6.0.40 meant to be used on Pro´s with the X5?
    Have tried to find somewhere where it´s confirmed but have had no luck so far.

    Thanks in advance to anyone that can clear this up.

    Best Regards
     
  2. Scotflieger

    Joined:
    Mar 29, 2015
    Messages:
    1,244
    Likes Received:
    575
    Location:
    Buckie, Scotland, UK
    FW 1.6 is only applicable to the standard Inspire 1 with the X3 camera. It is not for the I1 Pro unless you intend to fit an X3 to it.
     
  3. Quarts

    Joined:
    Nov 3, 2015
    Messages:
    10
    Likes Received:
    0
    Thanks, have got the impression from some firmware discussions that some people have updated their X5´s with the 1.6 FW so I was a little confused, because I have the latest FW that´s listed for the Pro but still see in the GO-app that it needs update.
     
  4. Scotflieger

    Joined:
    Mar 29, 2015
    Messages:
    1,244
    Likes Received:
    575
    Location:
    Buckie, Scotland, UK
    It maybe that your batteries are not to the latest standard. If you switch on hidden files on your computer you can view an additional of which lists the individual subsystem files on your aircraft and those changed.
     
  5. Quarts

    Joined:
    Nov 3, 2015
    Messages:
    10
    Likes Received:
    0
    That is possible. Will try to update them when they finished charging.

    Thank you :)