Welcome to InspirePilots.com

Join the leading DJI Inspire community for free!

Landing gear not responding

Discussion in 'General Discussion' started by PerthPilot, Jun 26, 2016.

  1. PerthPilot

    PerthPilot Guest

    Something wrong with my landing gear, when I take off, it says landing gear raising on my app but nothing happens on the inspire. Same with landing. I can adjust the worm drive manually
  2. The Editor

    The Editor Moderator
    Staff Member

    Aug 7, 2013
    Likes Received:
    Since it appears you have already tried turning the worm screw manually and it still doesn't respond we can assume it isn't stuck.
    Have you kept up maintenance on the drive and bearings with grease/lubricant and regular intervals?

    Sound like it is landing gear servo shot - not uncommon.
  3. PerthPilot

    PerthPilot Guest

    where would I find this landing gear servo?

    It was working before I updated the firmware
  4. Dave Armbrust

    May 27, 2016
    Likes Received:

    It does sound like a bad servo, but it concerns me that you just updated the firmware.

    Did you check the logs on the update? Did it look like it was successful? Probably a good idea to post it here, so that we can take a look at it.

    Did you update the controller as well?

    You did not mention anything about travel mode, which makes me wonder if this is working. Normally we leave our birds in travel mode which would result in your post stating it will not leave travel mode if you had a bad servo. What mode was the gear in when you did the update? Did you try to put it into travel mode after the update?

    Did you try all four methods of actuating the gear?

    1) Automatically upon take off
    2) Manually using the switch
    3) Enter travel mode through the app
    4) Enter travel mode by moving the switch quickly at least four times.

    You probably have tried most of these, but since it could be a update or firmware issue lets see if ANY of this works.
  5. Brendan

    Apr 20, 2015
    Likes Received:
    Check the firmware (1.9). I actually had this happen yesterday to me along with a number of the reported 1.9 errors. I will be rolling back to 1.8. It responded again once I rebooted the inspire. I also got a compass error in flight and less than responsive collective. My gear was locked down.

    Have never had any issues with the inspire before this and always run through my preflight checks. I landed fine and inspire appeared to be fine on reboot, but is definitely a bug in new firmware. Compass was a fine before takeoff (1400-1600 range), and had jumped to 1700-1700 after error. Was calibrated in an open field and not near any interference sources. The landing gear/compass error/and lack off collective response appear to be three particular bugs with the new firmware. These all disappeared on reboot.