Welcome to InspirePilots.com

Join the leading DJI Inspire community for free!

Litchi users

Discussion in 'News' started by huppe, Oct 7, 2015.

  1. huppe

    Joined:
    Jan 11, 2015
    Messages:
    899
    Likes Received:
    317
    Just got a message from Vtech(Litchi) that forthcoming firmware upgrade will not compatible with Lichi,so I suggest if you use Litchy wait awhile.
    Quote from Vtech:do not install this firmware, it is not compatible with Litchi.
     
    Machoman likes this.
  2. Machoman

    Joined:
    Jul 22, 2015
    Messages:
    316
    Likes Received:
    69
    Well Litchi works very well like it is with actual firmware. Why should they risk getting more limits as already happened (Orbit radius, speed)?

    It would only make sense if DJI lifts restrictions or brings fantastic new features in firmware (no idea what this could be) that outweights the disadvantages.
     
  3. huppe

    Joined:
    Jan 11, 2015
    Messages:
    899
    Likes Received:
    317
    You can be sure that hidden limits will appear in new firmware.Like the never mentioned lower speed.
    But I only bring this because I did got this message from Vtech
     
    crashburn likes this.
  4. huppe

    Joined:
    Jan 11, 2015
    Messages:
    899
    Likes Received:
    317
    OK here is an update which I Got from Vtech:
    The SDK 2.4 has no new "big" features that Litchi did not already have, unless I missed something.
    We will not create a separate app as it would require another DJI developer license and we will not maintain a 2nd version because it is a lot of extra work which we'd rather spend on new features. If you choose to stay on the old firmware when DJI releases the new public firmware, then you should also stay on the old version of Litchi, simply because we will no longer test/support older firmwares.
    The new SDK 2.4 will set a altitude limit while using Litchi.I use Litchi when flying in mountains and start at the bottom.Meanwhile I stay at 30 mtr above the ground I can go up over 500 mtr altitude.
    I do this for my job to make this clear.
    When I bought the Inspire these limits where not there.I do understand when you go up 120 mtr vertical above that it will be dangerous and I don't do this.
    But it 's clear to me that more limits will be build in with the new firmware,so for me upgrading comes to an end.
     
  5. Machoman

    Joined:
    Jul 22, 2015
    Messages:
    316
    Likes Received:
    69
    I agree I will also not update. I understand why Litchi does this its just because 99% of customers will fall into the trap and get the limits. Only few will know about it and stay away.

    Maybe they will think again when there come more new limits and they cannot get out any advantage over DJI GO anymore in future.
     
  6. HoMeturf

    Joined:
    Aug 4, 2015
    Messages:
    21
    Likes Received:
    0
    I
    I am interested in Litchi and needed to know if DJ GO app is required to run Litchi. In reading posts I see members listing DJ GO version.
    When DJI released Go App 2.4.1 , running on a Samsung Tab S it would not connect to RC but no issues with earlier versions, is this an issue with Litchi?
    How long can you upgrade once you buy the app? forever?
     
  7. Steve Reid

    Joined:
    Jul 2, 2015
    Messages:
    96
    Likes Received:
    8
    Location:
    Saint Cloud, Florida
    Have you looked at Airnest? Cool and simple to use.