Welcome to InspirePilots.com

Join the leading DJI Inspire community for free!

Micro SD doesn't lock into place

Discussion in 'Inspire 1 Help' started by Quarts, Dec 2, 2015.

  1. Quarts

    Joined:
    Nov 3, 2015
    Messages:
    10
    Likes Received:
    0
    Hi,

    Yesterday i took out the Micro SD card to download the latest footage to my computer.
    When putting the memory card back into the camera (X5) it wouldn't lock into place but kept getting ejected.
    I can hear the clicking sound from the locking mechanism but it doesn't lock even if I use another Micro SD to make sure I push it all the way to the bottom.

    Does anyone here know what might cause this or better yet, a solution to this problem?

    And also, is it a "very" bad idea to open up the back of the camera to try and find the problem and fix it myself? (Don't want to risk having it "stuck" for weeks at the service and miss out on the nice christmas and new year shots)

    Thanks in advance for any help.

    //Martin
     
  2. The Editor

    The Editor Moderator
    Staff Member

    Joined:
    Aug 7, 2013
    Messages:
    6,718
    Likes Received:
    3,871
    Sounds as though you have a faulty MicroSD card socket latch. They are surface mounted and not really serviceable by the end user.
    Sorry to be the bearer of bad news. :(
     
  3. lowe

    Joined:
    Dec 6, 2015
    Messages:
    1
    Likes Received:
    0
    my X5 is doing the same thing what should i do
     
  4. The Editor

    The Editor Moderator
    Staff Member

    Joined:
    Aug 7, 2013
    Messages:
    6,718
    Likes Received:
    3,871
    Ummmmm.....this doesn't bode well. H3-3D quality control all over again?? :rolleyes:
     
  5. Quarts

    Joined:
    Nov 3, 2015
    Messages:
    10
    Likes Received:
    0
    I have contacted DJI via the website and they immediately sent me a RMA after I provided them with the info they needed. Told me to send it to their service facilities in the Netherlands.

    BUT... I also have another X5(the original one) that needs repairing after an incident that left the gimbal torn apart and bent, so I opened a separate support enquiry for this one together with a check of the left side landing gear which also got a little twisted in the incident.
    And since they wanted the aircraft for testing the camera in the SD-card issue, they decided to put the 2 support enquiries into 1. They therefor asked me for some additional info which i also gave them but haven´t heard anything since I e-mailed them last Thursday.

    I´m hoping to hear from them tomorrow so I can send it to them before I go for a 10 day vacation.

    BTW - Thanks for your answer Mr Editor, even if it was´t what i was hoping to hear :)