Welcome to InspirePilots.com

Join the leading DJI Inspire community for free!

New Inspire Pro 1 Firmware Upgrade Question

Discussion in 'Photos and Videos' started by Brian Weis, Dec 7, 2015.

  1. Brian Weis

    Joined:
    Oct 27, 2015
    Messages:
    24
    Likes Received:
    2
    Location:
    Milwaukee, WI
    First off, I am a long time Phantom Flyer/Pilot and been stalking this and the DJI forum for along time. Reading, learning, researching. Thanks to everyone who contributes.

    I am T minus 2 days from receiving my Inspire 1 pro. When I go to upgrade do I grab the latest and greatest Firmware (FW) on DJI's site or do I install the oldest install that and then do the next current one until I get to the latest and greatest?

    Thanks in advance!
     
  2. Scotflieger

    Joined:
    Mar 29, 2015
    Messages:
    1,244
    Likes Received:
    577
    Location:
    Buckie, Scotland, UK
    To my knowledge there has only been one FW issued for the I1 Pro and X5 (1.1.0.40). The latest I1 standard update 1.5.0.30 is not applicable to the I1 Pro unless you have and can fit the X3 camera. You may find that the RC needs to be updated to 1.5.70 via the GO app (iOS 2.4.2). Otherwise you will need to wait for I1 Pro update to be released.
     
  3. FlyHighUSA

    Approved Vendor

    Joined:
    Oct 1, 2015
    Messages:
    935
    Likes Received:
    317
    Location:
    Munfordville Ky
    The proper upgrade has been fixed and is now available by going to the DJIJ X5 download page and looking for the firmware dated today 12/10/15. This fixed my issue of my bird saying it needs updating after I just updated it. Here are my results pics, I just went out and done a flight and everything is working perfectly, If anyone has any questions please just send me a message. Happy Flying...

    Ralph @ FlyHighUSA IMG_0827.JPG IMG_0828.JPG
     
  4. Gabsoo Kim

    Joined:
    Dec 10, 2015
    Messages:
    2
    Likes Received:
    0
    I have Inspire 1 added X5 camera. The bird is not Pro version.
    Do I have to update the firmware using version dated 10 Dec from Inspire1 Pro webpage or the verion dated 9 Dec from X5 camera webpage? Really DJI confusing user.
     
    #4 Gabsoo Kim, Dec 10, 2015
    Last edited: Dec 10, 2015
  5. Scotflieger

    Joined:
    Mar 29, 2015
    Messages:
    1,244
    Likes Received:
    577
    Location:
    Buckie, Scotland, UK
    I am in the same position as you. I updated my Inspire 1 (standard) using the X3 on Monday using I1 FW 1.5.0.30 and downloaded and installed the X5-only FW 1.2.0.50 (dated 9 Dec 15) yesterday from the DJI Zenmuse Z5 download page. This was before the errors in the firmware for the I1 Pro were identified. You should not use the latest I1 Pro firmware (1.2.0.50 dated 10 Dec 15) on the Inspire 1 (standard).

    Today I went to fly and got the 'Firmware required update' warning in the GO App. However, after calling up the About page and confirming I had the correct software, the warning disappeared. I flew 2 flights with no issues.
     
    Gabsoo Kim likes this.
  6. Gabsoo Kim

    Joined:
    Dec 10, 2015
    Messages:
    2
    Likes Received:
    0
    Today, X5 camera version was also changed to Dec. 10 instead of previous Dec. 9. Thanks.
     
  7. Scotflieger

    Joined:
    Mar 29, 2015
    Messages:
    1,244
    Likes Received:
    577
    Location:
    Buckie, Scotland, UK
    Many thanks. The X5 1.2.0.50 dated 10 Dec is identical to that dated 9 Dec. When inserted into the X5 the start up is normal with no update beeps or tones. Again changing the date on a file is not good software configuration control. My Inspire 1 with X5 is at this standard - the first 2 lines [01 00] and [01 01] relate to the X5 camera and gimbal:

    [00012604]========== remo-con disconnect. boot(15) ============
    [00012650]Packet [C:\WM610_FC550_FW_V01.02.00.50.bin] detected, card sn [0x916224c2].
    [00012695]Packet upgrade start...

    [00012744]Packet checking...
    [00012792]Packet vlink 01.02.0050 <-> 01.00.0030.
    [00012858]Record vlink 01.02.0050 <-> 01.00.0030 (flow = 0).
    [00012906]Done.

    [00012951]Version checking[1]...
    [00012997][01 00][00] v1.9.4499 -> v1.9.4499
    [00013046][01 01][00] v1.9.4499 -> v1.9.4499

    [00013096][01 04][00] v0.2.4270 -> v0.2.4270
    [00013153][04 00][00] v1.28.0.15 -> v1.28.0.15
    [00013232][03 05][00] v34.1.0.5 -> v34.1.0.5
    [00013292][03 06][00] v2.4.0.5 -> v2.4.0.5
    [00013392][05 00][00] v3.0.6.2 -> v3.0.6.2
    [00013447][08 00][00] v2.14.9.26 -> v2.14.9.26
    [00013552][09 00][00] v1.8.0.0 -> v1.8.0.0
    [00013632][11 00][00] v3.8.15.4 -> v3.8.15.4
    [00013732][12 00][00] v1.11.0.0 -> v1.11.0.0
    [00013813][12 01][00] v1.11.0.0 -> v1.11.0.0
    [00013913][12 02][00] v1.11.0.0 -> v1.11.0.0
    [00013993][12 03][00] v1.11.0.0 -> v1.11.0.0
    [00014107][15 00][00] v1.1.2.0 -> v1.1.2.0
    [00014193][17 00][00] v1.1.0.4 -> v1.1.0.4
    [00014314][17 01][00] v2.0.1.2 -> v2.0.1.2
    [00014377][19 00][00] v1.0.8.96 -> v1.0.8.96
    [00016420]Packet upgrade cancelled at version checking.
     
  8. FlyHighUSA

    Approved Vendor

    Joined:
    Oct 1, 2015
    Messages:
    935
    Likes Received:
    317
    Location:
    Munfordville Ky
    Hello there,

    The Inspire 1 flyers should update the bird using the firmware from the inspire 1 page. The update the camera with the
     
  9. Scotflieger

    Joined:
    Mar 29, 2015
    Messages:
    1,244
    Likes Received:
    577
    Location:
    Buckie, Scotland, UK
    Your comment is missing something on the end. True. The Standard Inspire 1 should be updated using the X3 with 1.5.0.30 and the X5 (upgrade) requires the X5 download 1.2.0.50 (now dated 10 Dec).
     
    The Editor likes this.
  10. FlyHighUSA

    Approved Vendor

    Joined:
    Oct 1, 2015
    Messages:
    935
    Likes Received:
    317
    Location:
    Munfordville Ky
    That wasn't the case for my bird. I upgraded using the 12/9/15 1.2.0.050 and kept getting the upgrade needed message. Then upon release of the same numbered firmware on 12/10/15 I upgraded it again with a successful result with no upgrade firmware message. It did for me go through the entire process. Of red and green camera lights etc... Not sure why ours worked differently.
    Thanks