Welcome to InspirePilots.com

Join the leading DJI Inspire community for free!

OSMO shows firmware 1.0.1.1.9+

Discussion in 'Osmo (Handheld Gimbal)' started by Mr Phantom, Feb 13, 2016.

  1. Mr Phantom

    Joined:
    Jun 19, 2015
    Messages:
    294
    Likes Received:
    25
    I noticed that my OSMO handle with the Inspire 1 X3 camera/gimbal shows firmware version 1.0.1.1.9+ and it doesn't prompt me to update..............................

    EDIT: It seems i have found the answer to my question, this firmware is the first firmware. But i still don't understand why it does not prompt me to update?
    Well i just have to update to the latest firmware, i just hope it doesn't brick the OSMO like the 25 December firmware did to some OSMO´s, and that most of DJI´s firmwares have a pretty huge potential to do.
     
    #1 Mr Phantom, Feb 13, 2016
    Last edited: Feb 13, 2016