Welcome to InspirePilots.com

Join the leading DJI Inspire community for free!

Cant connect X5pro to Inspire

Discussion in 'Zenmuse X5' started by gingericeman, May 27, 2016.

  1. gingericeman

    Apr 14, 2015
    Likes Received:
    Hi. I just received my Inspire Pro today, but I cant seem to get the gimbal to attach to the aircraft. The locking mechanism only seems to turn half of the way and then no further. I dont want to force it. I think I know the issue. The rubber seal on the top mounting part of the zenmuse is loose and kind of sticking up slightly. I think this is preventing the mechanism from fully locking. Is this rubber seal fully necessary? As far as I can see that is all that's wrong? What do you think?

    Attached Files:

  2. Scotflieger

    Mar 29, 2015
    Likes Received:
    Buckie, Scotland, UK
    I assume that your new Inspire 1 Pro has the wider camera attachment plate fitted. It is important to engage the tongue on the opposite end to the camera gimbal in the slot at the rear before presenting the connector into its socket. If it is not correctly supported and aligned the lock will not engage fully.
  3. The Editor

    The Editor Moderator
    Staff Member

    Aug 7, 2013
    Likes Received:
    The rubber damper (seal) IS necessary and nealy all of them are as you have pictured so that isn't the issue.
    As @Scotflieger mentions above, make sure you engage the tongue part at the rear first then offer up the connecting part, then turn the locking mechanism.
    On a lot of them there is really much in the way of a positive click when the lock is rotated more of a 'feel' it is engaged.
    As it is new it can be quite stiff.