Welcome to InspirePilots.com

Join the leading DJI Inspire community for free!

Inspire1 Firmware update v1.5

Discussion in 'Inspire 1 Help' started by GB44, Dec 12, 2015.

  1. GB44

    Joined:
    Jun 20, 2015
    Messages:
    43
    Likes Received:
    1
    Tried to update the Inspire with the latest version last night, after 4 hours just got failure tones.

    Never had problems before so can't understand this.

    Tried downloading update bin file again, tried different memory cards, tried with different batteries, reformatted memory cards, recharged batteries fully, reinstalled Go App, but still get failure tone on aircraft. However, when removing memory card and switching on aircraft the App displays as up to date firmware installed.

    When reviewing the memory card text file after the update/ failure it displays success initially but then this changes to Failure.

    Any suggestions welcome as I am running out of ideas ...
     
    #1 GB44, Dec 12, 2015
    Last edited: Dec 12, 2015
  2. Waternut13134

    Joined:
    Nov 15, 2015
    Messages:
    67
    Likes Received:
    17
    Do you have the X3 attached?
     
  3. GB44

    Joined:
    Jun 20, 2015
    Messages:
    43
    Likes Received:
    1
  4. GB44

    Joined:
    Jun 20, 2015
    Messages:
    43
    Likes Received:
    1
    Why do you ask. How else would you update ??
     
  5. TommyJeep

    Joined:
    Nov 29, 2015
    Messages:
    28
    Likes Received:
    2
    Location:
    Foresthill, CA
    I think he was asking if you have the x3 or the x5.

    What version are coming from? Perhaps you need to not skip a revision and step your way up to the most recent.
     
  6. GB44

    Joined:
    Jun 20, 2015
    Messages:
    43
    Likes Received:
    1
    Yes I was updating to the next version.

    Currently wiping and formatting cards.

    Just tried downgrading to v3 and now upgrading to 1.5. it seems to be bleeping correctly at the minute longer than previous attempts so something might be going right. Holding my breadth.

    Failed again.

    Tried formatting card in App and downloading update bin file again - still failed.
     
    #6 GB44, Dec 12, 2015
    Last edited: Dec 12, 2015
  7. GB44

    Joined:
    Jun 20, 2015
    Messages:
    43
    Likes Received:
    1
    I note there are now others reporting similar failed notices for this v1.5 update on the DJI Forum, so obviously some bug present
     
  8. Catvet

    Joined:
    Oct 6, 2015
    Messages:
    11
    Likes Received:
    0
    I'm having upgrade problems also. Downloaded .bin file and placed on card. Put in x5 turned on inspire. No updating taking place. Blinking yellow light if I don't have RC turned on. ATTI mode if I do (I'm inside). Tried new download and different card but doesn't kick into update mode when turned on.
     
  9. GB44

    Joined:
    Jun 20, 2015
    Messages:
    43
    Likes Received:
    1
    There's obviously something about this update. If anyone hasn't updated as yet, I would seriously be tempted to hold off for a few weeks to see if there is a solution offered by DJI
     
  10. The Editor

    The Editor Moderator
    Staff Member

    Joined:
    Aug 7, 2013
    Messages:
    6,729
    Likes Received:
    3,884
    Probably because it is not meant for the X5 and never was. This update MUST be actioned using the X3 and says so in the release notes.
     
  11. Frank508

    Joined:
    May 9, 2015
    Messages:
    171
    Likes Received:
    92
    Location:
    SF Bay Area
    Are we supposed to read those?
     
  12. GB44

    Joined:
    Jun 20, 2015
    Messages:
    43
    Likes Received:
    1
    Well I am using the X3 original camera and it simply doesn't work. Now I am left with a dead bird with no resolution on the horizon.

    As others are reporting similar occurrences it obviously is the update file and to make things worse it won't allow you to downgrade back to earlier versions it just kills the bird.

    So if you haven't upgraded yet DONT
     
  13. The Editor

    The Editor Moderator
    Staff Member

    Joined:
    Aug 7, 2013
    Messages:
    6,729
    Likes Received:
    3,884
    Nah.....nobody does anyway (or it seems that way when I read a lot of posts on this forum) :p
     
  14. andrew259

    Joined:
    Oct 18, 2015
    Messages:
    197
    Likes Received:
    85
    Just to say - I've upgraded my x3 and x5, and both my inspires and all is well...
    Sounds like I'm in the minority.


    Sent from my iPhone using Tapatalk
     
  15. GB44

    Joined:
    Jun 20, 2015
    Messages:
    43
    Likes Received:
    1
    Pleased to hear Andrew.

    I was hoping to get out today but sadly its in its little box dead as I can find anyway to fix this, but soon as I get it fixed I will post how
     
  16. The Editor

    The Editor Moderator
    Staff Member

    Joined:
    Aug 7, 2013
    Messages:
    6,729
    Likes Received:
    3,884
    No - think you are in the majority. If there were a major issue we would be hearing about it on the forum and we are only getting maybe 10 people who have had 'issues'. That's under 1%.
    A good proportion of those tried updating using the X5 or didn't read the release notes to see that the 1.5 update was for the standard x3 equipped Inspire only.
     
  17. GB44

    Joined:
    Jun 20, 2015
    Messages:
    43
    Likes Received:
    1
    How are you so sure the good majority were wrongly using the X5 to update. I can confirm I didn't use X5 as I dint have one and others on the DJI forum also have said they were using x3. Even if there was just one issue DJI should be more proactive to fix and find a solution other than directing individuals to other Forums for an answer. That is totally out of order and unreasonable from the manufacturer who caused the problem in the first place.

    However I don't think its helps those who are experiencing problems by inferring they have done something wrong by using an X5. I am pleased for those who have updated, but for those who haven't taken the plunge as yet, personally I would be waiting a few more weeks before updating.

    Lets be totally honest here, I have had no problems with updating since the beginning of the year until this version and the aircraft was flying very well without problems prior to this update. So there is no real reason to rush to do the update until DJI sorts this out for the benefit of everyone.
     
  18. The Editor

    The Editor Moderator
    Staff Member

    Joined:
    Aug 7, 2013
    Messages:
    6,729
    Likes Received:
    3,884
    Fair enough, but we are certainly not seeing a trend over here.
    I tend to stay away from the DJI Forum as there is so much bad advice and misinformation over there although I do speak to Ed Windham regularly and I talk with DJI R&D.
    There are way too many 'Out of the box, Wheeee look how high it goes' members over on that forum. :p
     
  19. GB44

    Joined:
    Jun 20, 2015
    Messages:
    43
    Likes Received:
    1
    Ok Mr Collie dog/ Editor/ Moderator - a name would be much better, I feel I can't respond properly or appropriately. How about Shep the Editor !! - Only joking ...

    I agree with some of your comments, but there are still some good guys there. Those see how high I can fly also annoy the hell out of me, but equally when I watch DJI sponsored films where they fly over highways, city centres and public are equally dangerous and annoying.

    Ed Windham is a good guy, but never seen him much of him on the DJI forum lately, I think there are new DJI moderators popping up each week, so perhaps he is just been replaced and is enjoying his time flying these days which is what we all really would like.

    What I can't understand though is the mentality of a DJI moderator telling me to go seek out a solution on other forums such as the RC Group. This current v1.5 update issue is a DJI created problem and they should be looking for a solution not outside forums. This is just so unreasonable and simply wrong.

    At the minute I can't see a solution on the horizon and suspect it will need to be shipped back to DJI to renew motherboard or something drastic as all the normal things we try or suspect simply have not worked.

    Anyway its nice to get some feedback and banter though.

    Happy Christmas and best wishes to all....
     
  20. ajohnsonlaird

    Joined:
    Mar 4, 2014
    Messages:
    139
    Likes Received:
    56
    By way of setting the scene, there seem to be three different models of Inspire 1:
    1. Inspire 1 with X3.
    2. Inspire 1 upgraded to X5 (so owners have both X3 and X5).
    3. Inspire 1 Pro that comes with X5

    I have the second item: I1 upgraded to X5 so I have both an X3 and an X5.

    Currently, there are two choices for firmware:
    1. Inspire 1 Firmware v.1.5.0.30 (see Inspire 1 - Specs, FAQ, manual, video tutorials and DJI GO | DJI) with Inspire 1 release note dated 2015-12-07, on the same page as this firmware. This release note says: "2. The X3 gimbal on the Inspire 1 is now compatible with the Osmo. Note that you must attach X3
      gimbal to the Inspire 1 before updating the firmware
      ."
    2. Inspire 1 Pro Firmware v1.2.0.50 (see Zenmuse X5’s specifications, FAQ, video tutorials, and DJI GO | DJI). No release note has been provided so one cannot be too sure whether it should be used for model 2. or 3. or both above.
    So, if I understand this correctly, and right now I'm not sure I do, then what I have to do is:
    1. Hang the X3 camera on the inspire and update to version 1.5.0.30.
    2. Then cycle through all six batteries in turn (the Release Note indicates that "2. Battery firmware is included in this All-in-One firmware update. Update all Intelligent Flight Batteries by using this firmware."
    3. Then hang the X5 camera on the Inspire and update to version 1.2.0.50. (If I don't do this then how will the X5 get updated -- and without a release note who knows what it's updating?)
    Add to that the contents of this thread: FW 1.2.0.50 - Do not update | Page 2 | DJI Inspire Forum which suggests that 1.2.0.50 "refers to the X5 camera firmware version".

    InterMurph wrote:
    "Because the latest aircraft firmware is included in today's Pro firmware release, the solution is simple: all X5 owners should download today's Inspire 1 Pro update (v1.2.0.50), and everything should be up to date. Your aircraft should end up at version 1.5.0.30, and your camera should end up at version 1.2.0.50. And the DJI Go app should not complain about needing an update."​

    But then how do I update the X3?

    I'd really love to avoid the "I've totally bricked my Inspire 1" posting.

    Note to DJI: Please clarify what is going with the three different models and the two different firmware versions, one without a Release Note.

    Bonus points to Intermurph for only using the word "fiasco." I can think of other F-words that might also apply. (Moderators: Think "Folly," "Foolishness" -- I'm sure there must be others... :rolleyes:)

    For now, I'm applying the age-old philosophy: If in doubt, do nothing. In fact I would leave things as they are -- except for the fact that DJI's Auto-Brick feature will prevent the Inspire 1 from flying if I don't do something.

    All this on top of the FAA's sUAV registration....sigh...
    Andy.