Welcome to InspirePilots.com

Join the leading DJI Inspire community for free!

New TB47 battery won't charge

Discussion in 'General Discussion' started by Yellow Fellow, Feb 19, 2016.

  1. Yellow Fellow

    Joined:
    Sep 23, 2015
    Messages:
    18
    Likes Received:
    3
    Location:
    UK
    Hi.

    I'd be grateful if someone who is cleverer than me has any insights into the following problem. Although there are other threads on charging issues, I haven't seen this specific issue flagged anywhere, so don't think I'm replicating anything.

    A couple of weeks ago I (pleasingly) received a replacement TB47 battery for one that had developed a fault. I did a quick visual check of the charge and saw that it appeared to be at the around the 2/3 storage charge level (ie LEDs 1 and 2 light up and LED 3 flashes).

    I didn't use it immediately (weather), but when I came to charge it yesterday, I noticed the following:

    - When the button is pressed LED 1 flashes 6 times (suggesting a very low battery level).

    - When plugged into a charger, LED 1 flashes 5 times then goes out. The battery doesn't charge. I tried it in three different chargers, which are all working fine with my other batteries.

    I feel like it's trying to tell me something, but I'm not sure what... Can anyone advise on whether they think there's something obvious I'm overlooking or if I've just landed myself with (another) dud battery...

    Thanks.
     
  2. Alastair

    Joined:
    Jul 15, 2015
    Messages:
    276
    Likes Received:
    62
    Location:
    Prince Edward Island, Canada
    I would just send it back.... But if you want to try, you could pry the top of the battery, like others have done, disconnect the circuit board and wait a few minutes and reconnect. This should reset the the electronics. Then recharge. Check and make sure this action doesn't void your warranty first.
     
  3. Waternut13134

    Joined:
    Nov 15, 2015
    Messages:
    67
    Likes Received:
    17
    I had something like this happen when I got new batteries. Make sure you have the most up to date firmware on the memory card,put the battery in the inspire 1 and turn it on without the controller connected. This will update the firmware on the battery. After it's done then try to charge the battery and see if it works.
     
  4. Yellow Fellow

    Joined:
    Sep 23, 2015
    Messages:
    18
    Likes Received:
    3
    Location:
    UK
    Thanks, guys. Unfortunately, there isn't enough charge in the battery to turn it on... So I guess I'll end up sending it back again!
     
  5. Angelo Russo

    Joined:
    Jun 21, 2015
    Messages:
    3
    Likes Received:
    0
    I'm facing a very strange issue on my almost new TB47.
    If I click once it shows the four leds solid green but no way turning it on, neither on the inspire.
    When I put charging it shows the led 4 blinking twice with no stop, even if I disconnect the charger.
    Latest firmware on (as other batteries with no issues) and 4 charging cycles....
    Any clues ?
     
  6. gray52

    Joined:
    Aug 5, 2014
    Messages:
    363
    Likes Received:
    52
    Connect to your charger. Turn the battery on as if it's in your inspire. Should then start charging. Enjoy:).
     
  7. Angelo Russo

    Joined:
    Jun 21, 2015
    Messages:
    3
    Likes Received:
    0
    Thanks for your post.
    Unfortunately the battery shows same attitude when on ispire. No way to turn it on, even if I got 4 solid green leds (clicking once).
    This is very frustrating...
    It's my battery issue number 3.
    :-(
     
  8. gray52

    Joined:
    Aug 5, 2014
    Messages:
    363
    Likes Received:
    52
    Strange you have had 3 issues. Mine are 1 year old now and still fine. I trust them 100% and I'm now using a brand new pro.